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This document is I hope a short/quick tutorial on the bare bones basics of how to use Visio for 
the CIS 103 Programming Logic class.  There is a short tutorial built-in to the Visio software 
under the Help menu (Click Help on the menu, then the Getting Started Tutorial option).  You 
may further explore the features of Visio by doing this tutorial. 
 
Starting the Visio Program 
 
To start the Visio program: 

Click Start, All Programs, Microsoft Visio 2003 
Or 

Click Start, All Programs, Microsoft Office, Microsoft Visio 2003 
 

Running the Tutorial (Optional) 
 

1. Click Help on the menu, then click the Getting Started Tutorial option 
2. Follow the instructions on the screen 
3. Click the Next link to proceed through each lesson 
4. Click the play ► button to see the animations 

 
The First Screen in Visio 
 
When first start Visio you may get the following screen: 
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If you don’t get the above screen, then follow these steps: 
 

Click File on the menu, then New and then Choose Drawing Type 
 
Selecting the Basic Flowcharting Template 
 
In this class we will be doing program flowcharts.  The template we will be using is the Basic 
Flowchart U.S. version. 
 

1. Click Flowchart under the Category list on the left side of the Choose Drawing Type 
window pane. 

2. Click Basic Flowchart (US units) 
 

 
 
The Drawing Environment 
 
After you open a template, you'll see the Microsoft Office Visio drawing environment, which 
includes menus, toolbars, stencils with shapes, the drawing page, and a task pane to the right of 
the drawing page.  
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You create your drawing on the drawing page, which represents the printed page and includes a 
grid to help position shapes.  

You use the task pane to access various types of information quickly while you work or 
collaborate with other team members.  You can close X this pane if you want more drawing 
room and less scrolling. 

Visio menus and toolbars are similar to those in other Microsoft Office System programs, so 
you'll find familiar ways to open, print, and save your diagrams. 

Creating a Flowchart 
 
First you add shapes (process, decision, input/output shapes) and text to the shapes.  Then you 
add the connecting lines between the shapes.  Next you may want to add free form text to the 
diagram, such as a title or comments. 
 
Adding Shapes 
 
Add shapes to your diagram by dragging (hold down the left mouse button and move your 
mouse) shapes from stencils in the Shapes window onto the drawing page.  Don’t worry too 
much about lining the shapes up.  Visio helps you line up the shapes by “snapping” them to the 

Drawing Page 

Task Pane 

Stencil with 
Shapes 
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grid.  Please note that the grid shown on the drawing page does not print out when you print the 
diagram. 
 
Deleting Shapes 
 
Deleting shapes is easy. Just click the shape and then press the DELETE key. 
 
Move and Resize Shapes 
 
Moving a shape is easy: just click any shape to select it, and then drag it to a new location. 
Selection handles appear when you click the shape.  

1. With the Pointer tool  , click the shape to select it.  
2. Place the Pointer tool over the center of the shape.  

A four-headed arrow appears under the pointer  , which tells you that the shape is 
ready to be moved.  

You don't have to place the Pointer tool exactly over the center of the shape; but it's a 
good habit to develop so you don't drag a shape handle and resize the shape by mistake.  

3. Drag the shape to the desired location on diagram.  Release the mouse button.  

If you resize the shape by mistake, just undo your last action. (On the Edit menu, click 
Undo.) 

Please note you can also use your arrow keys to move shapes.  Use the combination of the shift 
key and arrow keys to move the shape in smaller increments. 
 
Moving More Than One Shape at a Time 
 
To move more than one shape at a time, you first select all the shapes you want to move.  

1. With the Pointer tool  , click a blank area of the drawing page above and to the left of 
the top shape, and then drag down and to the right to create a black selection rectangle 
around all of the shapes. 

Alternatively, you could hold down the SHIFT key while you click each shape. 

2. Place the Pointer tool over the center of any of the selected shapes. 

A four-headed arrow appears under the pointer , which tells you that the shapes are 
ready to be moved. 
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3. Drag the shapes to their new location on the diagram.  All the selected shapes move at 
once.  

Resizing Shapes 
 
You can resize shapes by dragging their corner, side, or bottom selection handles. 

1. With the Pointer tool , click the shape you want to resize.  

2. Place the Pointer tool over a corner selection handle .  

The pointer changes to a two-headed arrow , which tells you that the shape 
can be resized. 

3. Drag the selection handle inward to decrease the size of the shape.  Drag the selection 
handle outward to increase the size of the shape. 

Resizing Multiple Shapes at One Time 
 

You can resize multiple shapes at once by selecting all of the shapes you want to resize, and then 

dragging one of the selection handles   that appear on the green selection rectangle that 
encloses all of the shapes. 

Adding Text to Shapes 
 
You can add text to shapes. Just click a shape and begin typing; Microsoft Office Visio zooms in 
so you can see the text as you type.  

1. Click the shape on the drawing page, and then type the desired text.  

Alternatively, you could click the Text tool A, click the shape, and then type. 

2. Click a blank area of the drawing page or press the ESC key to exit the text mode. 

 
Deleting Text from a Shape 
 
Double-click the shape, and then, with the text highlighted, press the DELETE key. Or click the 
Text tool A, click the shape, highlight the text you want to delete, and then press the DELETE 
key. If you delete the shape by mistake, on the Edit menu, click Undo. 
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Adding Independent Text to the Diagram 
 
You can also add text that's not associated with any shape, such as a title or list, to the drawing 
page. This type of text is called independent text or a text block. Use the Text tool to just click 
and type. 

1. Click the Text tool A.  
2. Click the page where you want the text to appear on the diagram 
3. Then type the desired text. 

 
Deleting Independent Text 
 

Click the Pointer tool , click the text, and then press the DELETE key. 
 
Moving Independent Text 
 
You can move independent text as you move any other shape: just drag it. In fact, independent 
text is really just a shape with no border or color. 
 
Formatting Text 
 
You can format text—italicize it, underline it, center it, and so on—the same way you format 
text in any Microsoft Office System program. You can use buttons on the toolbar or options in 
the Text dialog box (on the Format menu). 
 
Connecting the Shapes with the Connector Tool 
 
In Visio, you create connections by attaching, or gluing, one-dimensional shapes called 
connectors to two-dimensional shapes.  
 
Connectors stay glued when you move the shapes. For example, when you move a flowchart 
shape connected to another shape, the connector repositions to keep its endpoint glued to both 
shapes. 
 
You use the Connector tool to create connections. 
 
Note   People new to Microsoft Office Visio often use the Line tool to connect shapes. Using the 
Connector tool is a much better method. When you use the Connector tool, connectors reroute, 
or bend, automatically when you move one of the connected shapes. When you use the Line tool 
to connect shapes, the connectors don't reroute. 

1. To zoom in on the top two shapes, hold down the CTRL+SHIFT keys while you drag a 
selection rectangle around the shapes.  

2. Click the Connector tool .  
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3. Place the Connector tool over the connection point on the bottom of the first Process 
shape.  

The Connector tool highlights the connection point with a red box , which tells you 
that a connection can be made at that point. 

4. Drag the Connector tool from the connection point on the first shape to the connection 
point at the top of the second Process shape.  

The connector endpoints turn red when the shapes are connected. This is an 
important visual cue. If one of the connector's endpoints is still green , use  the Pointer 
tool to connect the endpoint to the shape. Both endpoints must be red if you want the 
shapes to stay connected. 

5. To zoom out, press the CTRL+W keys.  
6. Experiment with selecting and moving a shape.  Notice that the text moves with the shape 

and the connector reroutes and remains connected to the two shapes.  

The connector reroutes because you used the Connector tool (and not the Line tool) to 
connect the shapes. 

 
Connecting Shapes Using Connectors in a Stencil 
 
You can also connect shapes with connectors from stencils. For example, in a block diagram, 
you can drag two-dimensional arrows from a stencil and connect them to boxes.  

1. For example connect two shapes with the Line-Curve connector.  From the Basic 
Flowchart Shapes stencil in the Shapes window, drag the Line-curve connector, and 

position it so the endpoint of the plain end of the connector connects to the 

connection point on the side of the first shape.  

The Line-curve connector endpoint turns red  when it is connected to the shape. 
The other endpoint is still green because you haven't connected it to a shape yet. 

2. Drag the other endpoint of the arrowhead end of the Line-curve connector onto the 
connection point on the side of the second shape.  

Both connector endpoints turn red when the shapes are connected. 
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Adding Text to Connectors 
 
You can use text with connectors to describe relationships between shapes. Add text to 
connectors the same way you add text to any shape—just click a connector and type.  A good 
example would be for Decision symbols.  One arrow will have Yes or True and the other arrow 
will have No or False. 
 
Adding Shapes Between Connected Shapes 
 
If you want to add a new shape between two connected shapes, you can. Just drag the new shape 
on top of the connector, and all three shapes automatically connect. 

Note   This works in the flowchart, electrical engineering, and process engineering templates. 

 
Saving the Diagram 
 
After you finish a diagram, you can save it the same way you save a file created in any Microsoft 
Office System program.  

Note   It's a good idea to periodically save your diagram as you work.  

1. On the File menu, click Save As.  
2. In the File name box, type Flowchart, and then click Save. 

Previewing and Printing the Diagram 
 
Before you print a diagram, you can preview it to ensure it will print correctly. In the Print 
Preview window, the gray boundary indicates the drawing page margins and edge of the printed 
page. Shapes that overlap this boundary won't print completely. Either move them or adjust your 
drawing page or printer settings, such as orientation, size, or margins. (To adjust page or printer 
settings, on the File menu, click Page Setup.) 

1. On the File menu, click Print Preview.  

Alternatively, you can click the Print Preview button . 

2. On the File menu, click Print.  

If you only want to print the current drawing page, you can click the Print Page button 

instead. 

3. In the Print dialog box, click OK.  
4. To exit print preview, on the toolbar, click Close. 
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More Tips 

Sometimes you will have several pages in a project.  So you will need to know how to add a 
new page and page numbers. Also, it is a good idea to add headings that repeat at the top of 
each page, such as “CIS 103 TUTH 9:30, Your Name.”  The following sections show you 
how to add a new page, add page numbers and a header. 

Adding a Header and Footer 

The steps are: 

1. Select View from the menu. 
2. Select the Header and Footer option, you will get the Header and Footer dialogue 

box: 

 

3. On the left side (Header), in the Center textbox type:  CIS103 TUTH 9:30, Your 
Name.  This will create a centered header at the top of each page. 

4. On the right side (Footer), for the Right textbox click the ► button, then click the 
Page number option.  It will insert the page code &p.  This will create a footer at the 
bottom of each page with the page number on the right margin. 

5. Click the OK button. 
6. Click the Print Preview button on the menu. 

You will not be able to see the header and footer on the diagram page.  You will only see 
them when you Print Preview or Print the document. 
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Adding a New Page 

To add a new page to your project, so the following steps: 

1. Select Insert from the menu. 
2. Select the New Page option. 
3. Click the OK button.  A new sheet of paper will be added to the project. 
4. Click the Page-2 tab to go to the new page. 

 

5. You now can begin to work on the second page.  Also you may copy textboxes, shapes, 
lines, etc. from the first page as needed. 

Please note the header and footer you created earlier will be printed and displayed in the 
Print Preview window. 



Visio 2003 Professional Basic Tutorial 

Prepared by Susan Fuschetto August 22, 2004 Page 11 

Changing the AutoCorrect Settings: 

Well if you are like me then you are tired of retyping the first character in a shape.  Have you 
noticed that as you type in a shape Visio automatically capitalizes it?  I hate this.  To change this 
setting you do the following: 

1. Select Tools on the menu. 
2. Select AutoCorrect Options. 
3. Remove the check mark on the Capitalize first letter of sentences option. 

 

 

4. Click the OK button. 
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More Symbols: 

For the annotation symbol use: 

 

 

For the module symbol use the predefined process symbol: 
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For Hiearchy Charts: 

 

For hierarchy charts use the plain process symbol and no arrowheads on the flow lines.  You 
draw the chart and add the flow lines using the connection tool like you normally would do.  The 
flow lines will have arrowheads.  You need to remove the arrowheads.  To remove the 
arrowheads do the following steps: 

1. Select the flow line by clicking it.  You should see the connection points (red squares) 
and sizing handles (green X’s) on the line. 

2. On the Formatting Toolbar, select the Line Ends button, and then select the No Lines 
Ends Option: 

 

 


